Sign up for 3 or more webinars and save 25%!   Discount automatically calculated in cart

Sorry, an obsolete and insecure web browser has been detected.

Sorry! We've detected that you are using an old web browser that is not able to connect securely to this site. Specifically, your browser is limited to an old encryption protocol, TLS version 1.0.

In order to safeguard the data of our users, this site can no longer support TLS 1.0. Please upgrade your web browser to the newest version available and then return to this site.

This site can guide you to the latest secure version of your preferred web browser.

If you are using Internet Explorer, Microsoft no longer supports IE below version 11, and recommends that all users upgrade to their new browser called Edge. While we do not recommend IE below version 11, some older versions of Internet Explorer have security settings that may allow you to enable TLS 1.1 and TLS 1.2. Instructions to do that are here:

  • On the Internet Explorer main menu, select Tools > Internet Options.
  • In the Internet Options box, select the Advanced tab.
  • In the Security category, uncheck Use SSL 3.0, then check Use TLS 1.0, Use TLS 1.1, and Use TLS 1.2 (if available). NOTE: It is important to check consecutive versions. Not selecting consecutive versions (for example, checking 1.0 and 1.2, but not checking 1.1) could result in connection errors
  • Click OK.
  • Exit and restart Internet Explorer.

Note that you are leaving TLS 1.0 checked for compatibility with other websites that may not have made this security update yet. Most importantly, you will be ENABLING TLS 1.1 and TLS 1.2 which is required to access this site.

If you do not see TLS 1.1 and TLS 1.2 options, then your version of IE is no longer secure and you MUST upgrade to access this web site.